Email Invoice Processing – Error response received when processing unsupported file type
Yellow Dog Inventory Troubleshooting:
Email Invoice Processing – Error response received when processing unsupported file type
Issue:
User received the following unsuccessful processing response when sending an invoice for invoice staging:
“The following attachments were prevented from sending for additional processing -ATTACHMENT NAME.pdf – application/octet-stream is not an image or pdf type that is supported’

Causes
• The error message seen indicates that your email provider or email application has flagged the attached PDF as an unrecognized MIME type, blocking the attachment from being processed.
• MIME types are often blocked or flagged by email providers to prevent malware attacks.
Additional context
• Our system is not able to process flagged attachments.
• This flagging of the attached PDF is outside of the control of our software, and in instances of receiving this message, manual upload will be your next best step for invoice entry.
• While Yellow Dog supports image/jpeg, image/png, application/pdf formats for this feature, we are unable to control attachments that are flagged as suspicious/undeliverable by your email provider.
• NOTE: what works on one workstation may not work on another. This is dependent on email application settings. We are not able to speak to why some of your PDFs are being flagged by the email provider, but not others
Troubleshooting Steps
Download the attachment, confirm it is a supported file type and email it directly to
invoicestaging@yellowdogsoftware.com rather than forwarding the email and attachment from your vendor.
Verification Steps
You can verify that this was successful when you receive the automated confirmation email that the vendor approvals team has received your invoice and are working on processing it.
If you have downloaded the attachment, confirmed it is a format that Yellow Dog Retriever Service supports, and still receive an unexpected error response, please contact Yellow Dog Support directly:
• Phone: 757-663-7514
• Chat: Click here to Chat with a YD Support Guide
Support hours: Monday–Friday, 9:00 a.m.–8:00 p.m. EST
Emergency support (available 24/7): 757-663-7514, Option 1
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